Main (#1) - Link to join Professional Network is broken (#64) - Message List

Link to join Professional Network is broken
 unsolved

The professional network is described on this page:  http://wiki.openplm.org/trac/wiki/Professional#no1

To join, it refers you to this link which is broken:  https://openplm.org/shop/index.php?id_product=8&controller=product

How do you join (and download) OpenPLM 2.0?

Thank you.

  • Message #187

    They are undergoing some structural changes, and it is my understanding that the Professional Network is no more.

    I'm forwarding a recent message that offers a link to a Virtualbox image, not sure what version it is. I would also try getting the software via subversion.

    It's good software, and the price is very compelling, so I would encourage you to try it out even though the professional network is out of the picture. With any luck, it will continue to grow and be developed.

    Good Luck,

    Jesse Krenzelok


    Hello OpenPLM community,

    I just uploaded an OpenPLM 3D server. It's a Virtual Machine you can download and import in Virtualbox.

    You can download the 1.9 Gb file here :  http://wiki.openplm.org/trac/downloads/10

    Here is some tuto to learn how to install Virtualbox :  https://www.virtualbox.org/manual/ch01.html#intro-installing  http://www.youtube.com/watch?v=XajMLO8v65w

    Here is some tutos to learn how to import a Virtual Machine :  http://docs.oracle.com/cd/E26217_01/E26796/html/qs-import-vm.html  http://www.youtube.com/watch?v=axqiuZ883A8

    I teach PLM to students in an Engineering school and we installed this server for them. I just modify few things and uploaded it for you. I don't think it's 100% reliable and I may say it's a kind of alpha version. All your feedbacks and suggestions are welcome.

    Regards, -- Philippe JOULAUD


    • Message #273

      Hello, I downloaded the virtual machine and started it in virtualbox. The logins were shown for a first user with a password and admin with a password. These didn't work and the keyboard when typed displayed different characters than I typed. I experimented and used different characters so that they would match the actual login but that didn't work. This is frustrating.

  • Message #188

    This was two months ago, and the URL is still not functional. It also seems the last commit was 4 months ago... are the developers dead?

    edit: also, I'm not going to be running this on a VM, I want to install this (OpenPLM) on a dedicated machine I have set up with debian minimal across a RAID1 array.

    • Message #189

      No, the developers are not dead- I spoke to M. Joulaud yesterday. My understanding is that the professional network is no more, but support is available for a consulting fee. I know he is still active with OpenPLM, because we are in the process of hiring him for some assistance with implementing our system company wide, and he has indicated that there are some other companies he is working with as well.

      If you don't want or need tech support, you can get OpenPLM from the subversion repositories- I've got a sandboxed version running right now from there that's been completely stable for months. That one is the 2.0.1 version.

      I can't speak for M. Joulaud, of course, but I am a big fan of this software and hope to see it gain enough interest and investment for him to resume full-scale development, so I would encourage you to contact him directly and see what you can work out.

      • Message #190

        So really I'll have to pull the source and compile it on my debian system? I'm not complaining, just wondering if there is a deb package of it around somewhere to save some time.

        Thanks for the quick reply.

        • Message #191

          Yes and no.

          As I've installed this a couple of times, and gone through the configuration process, I can tell you a little about how it works.

          What you want to do is install all the prerequisites according to the installation instructions on this site. It's been a few months since I did this, but most, if not all, of them were simply acquired with apt-get (and the first time I did it using OpenSUSE, zypper.)

          When you download OpenPLM from Subversion, it does not require compilation- it's not really a program, it is more of a website. So you do have packages for Apache, Django, Xapian and Haystack, and OpenPLM is really a collection of .css files and uncompiled .py files that put themselves in the right places when you download from Subversion.

          This is actually really nice to work with. The structure makes it easy to change things on the fly, and customize as you like without worrying that a single typo will take your whole site down. There is no ./make or ./compile to fail, just a lot of human-readable files that you can edit and test.

          Document3D is an exception to that, but as far as something this complex goes, it really is pretty user-friendly, as long as you are methodical and are not afraid of using VIM from the command line.

          So far as I know, M. Joulaud may have an install script, or at least is willing to create one, but that, like the connectors, is not free software. You will have to ask him about what is available. What I can tell you is that the first time I installed OpenPLM, I used OpenSUSE, and it took a few weeks to get running due to research into the differences from Debian, but the second install on Mint 13 took about three hours. Presumably, using Debian would be even faster, as it is the OS that the instructions were written for.

          • Message #192

            Hello,

            I'm just reading this thread and I thank Prometheus for his answers.

            He's correct about the components of the software and the way we install it. For detailed explanation, see the tuto :  http://wiki.openplm.org/docs/2.0/en/admin/ht_2_install_server.html

            For a Debian installation, someone who is experienced can install it in half hour, maximum 1 hour.

            LinObject, the company I founded and which developped OpenPLM does no longer exist.

            As it was already mentioned, I'm now OpenPLM consultant and I can support you in your installation, your developments and much more to have an efficient implementation and save your time.

  • Message #231

    i have downloaded openplmsever4community 2.0 and installed in virtual machine it require user name and password . so can you provide me login details or otherwise give me a link where i can find that. i have tried login as django and password as banana as well as login as first_user and password as carrot.

    • Message #232

      Normaly you should have a virtualbox window like this :

      http://wiki.openplm.org/trac/attachment/discussion/message/231/openplm4community.png

      If you don't have it, something wrong happened. It may be the VM network configuration. You should set "Network access mode" to "Bridge access" (i'm not 100% sure of English translation). This configuration authorizes the VM to get an IP adress from DHCP server.

      Once the VM can get the IP adress, you should have a picture similar to the herebefore picture. In it you can find the IP adress.

      Then, open your web browser (Firefox or other) go to the given IP adress.

      Finaly, enter the given login and password.

Attachments

No attachments created.