Main (#1) - A few installation questions (#48) - Message List

A few installation questions
 unsolved

Hello,

I believe I'm very close to having this installed and running, but there were a couple of issues that I would appreciate some clarification on.

When I run the ./manage.py commands, I get the following output. Is the "OperationalError:" line something I need to worry about?

openPLM:/var/django/openPLM # ./manage.py syncdb --all Syncing... OperationalError?: openPLM:/var/django/openPLM # ./manage.py migrate --all --fake OperationalError?: openPLM:/var/django/openPLM # ./manage.py loaddata extra_lifecycles OperationalError?:

The chown command shown in many of the steps lists www-data:www-data as the owner. On my system, it doesn't register as a legitimate user/group combo. Is this just a place holder for a system-specific name, or did I miss something?

openPLM:/var/django/openPLM # chown www-data:www-data /var/openPLM chown: invalid user: ‘www-data:www-data’ Do I need to make a user and a group for www-data?

At this point, ./bin/check_modules.py is giving me the all-clear, but when I restarted apache2 and tried to connect to it via localhost, it gives me a message telling me that I don't have permission to access the requested directory. My best guess is that it is related to the ownership issues on the folders.

Any advice?

  • Message #158

    Hi,

    I investigated and I found that :  http://forums.opensuse.org/english/get-technical-help-here/applications/477186-what-user-group-does-apache2-run-under-opensuse.html

    It seems the user and group for Apache server on OpenSuse? is wwwrun and www.

    I suggest to try these commands :

    # chown -R wwwrun:www /var/django/openPLM/trunk/openPLM/media

    # chown -R wwwrun:www /var/openPLM

    • Message #159

      Thank you- That worked, at least as far as the folder ownership goes.

      So now it looks like everything should be working- I did get the manage.py commands to compile correctly, (I had forgotten to restart postgres after a reboot.)

      Still one problem in there somewhere, and it's likely due to the fact that that is the first time I've tried to configure an Apache server.

      It is now returning an Error 500 server error, and the logs just say that the server rejected the connection. I am only trying to get this software sandboxed so that we can evaluate it, so it has no specific IP assigned, I am just attempting to connect with localhost for the moment.

      This is what I've edited in the file, including commenting out the section of code that stated that it forbade access to the entire filesystem by default. If you see anything that looks out of place, or if you know of some other location that I need to check to configure options, advice is always appreciated.

      WSGIScriptAlias / /var/django/openPLM/apache/django.wsgi

      # required to enable webdev access

      WSGIPassAuthorization On

      <Location /media/thumbnails>

      WSGIAccessScript /var/django/openPLM/apache/access_restricted.wsgi

      </Location>

      Alias /media /var/django/openPLM/media

      <Directory /var/django/openPLM/media>

      Order deny,allow

      Allow from all

      </Directory>

      # forbid access to the entire filesystem by default

      #<Directory />

      # Options None

      # AllowOverride? None

      # Order deny,allow

      # Deny from all

      #</Directory>

      • Message #160

        I'm not sure but if you go there :  http://wiki.openplm.org/docs/dev/en/admin/ht_2_install_server.html#configure-apache-server

        You just need to copy and paste the Apache configuration file.

        Very quickly, I see 2 main differences with your file :

        1- Several times you specify : /var/django/openPLM/

        And standard is /var/django/openPLM/trunk/openPLM/

        2- You also have : <Location /media/thumbnails>

        And standard is <Location /media/>

        • Message #161

          You won't believe this... When I clicked your link, I realized that I had been trying to install using the previous version's instructions. So I had moved directories, and missed a handful of crucial steps.

          At this point, it seemed like it would be easier to simply restart with a clean system, and so far, the instructions are working much better for me. Thank you once again for your assistance- I would have been beating my head against the wall forever if you hadn't posted the link.

Attachments

No attachments created.